You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
pleroma-fe/package.json

130 lines
4.2 KiB

7 years ago
{
"name": "pleroma_fe",
"version": "2.5.0",
"description": "Pleroma frontend, the default frontend of Pleroma social network server",
"author": "Pleroma contributors <https://git.pleroma.social/pleroma/pleroma-fe/-/blob/develop/CONTRIBUTORS.md>",
"private": false,
7 years ago
"scripts": {
"dev": "node build/dev-server.js",
"build": "node build/build.js",
"unit": "karma start test/unit/karma.conf.js --single-run",
"unit:watch": "karma start test/unit/karma.conf.js --single-run=false",
7 years ago
"e2e": "node test/e2e/runner.js",
"test": "npm run unit && npm run e2e",
"stylelint": "npx stylelint src/components/status/status.scss",
"lint": "eslint --ext .js,.vue src test/unit/specs test/e2e/specs",
"lint-fix": "eslint --fix --ext .js,.vue src test/unit/specs test/e2e/specs"
7 years ago
},
"dependencies": {
"@babel/runtime": "7.20.7",
2 years ago
"@chenfengyuan/vue-qrcode": "2.0.0",
"@fortawesome/fontawesome-svg-core": "6.2.1",
"@fortawesome/free-regular-svg-icons": "6.2.1",
"@fortawesome/free-solid-svg-icons": "6.2.1",
"@fortawesome/vue-fontawesome": "3.0.2",
"@kazvmoe-infra/pinch-zoom-element": "1.2.0",
"@kazvmoe-infra/unicode-emoji-json": "0.4.0",
2 years ago
"@ruffle-rs/ruffle": "0.1.0-nightly.2022.7.12",
"@vuelidate/core": "2.0.0",
"@vuelidate/validators": "2.0.0",
"body-scroll-lock": "3.1.5",
2 years ago
"chromatism": "3.0.0",
2 years ago
"click-outside-vue3": "4.0.1",
"cropperjs": "1.5.12",
2 years ago
"escape-html": "1.0.3",
2 years ago
"js-cookie": "3.0.1",
"localforage": "1.10.0",
"parse-link-header": "2.0.0",
"phoenix": "1.6.2",
2 years ago
"punycode.js": "2.1.0",
2 years ago
"qrcode": "1.5.0",
2 years ago
"querystring-es3": "0.2.1",
"url": "0.11.0",
2 years ago
"utf8": "3.0.0",
"vue": "3.2.45",
"vue-i18n": "9.2.2",
"vue-router": "4.1.6",
"vue-template-compiler": "2.7.14",
"vue-virtual-scroller": "^2.0.0-beta.7",
"vuex": "4.1.0"
7 years ago
},
"devDependencies": {
"@babel/core": "7.20.7",
"@babel/eslint-parser": "7.19.1",
"@babel/plugin-transform-runtime": "7.19.6",
"@babel/preset-env": "7.20.2",
"@babel/register": "7.18.9",
2 years ago
"@intlify/vue-i18n-loader": "5.0.0",
"@ungap/event-target": "0.2.3",
"@vue/babel-helper-vue-jsx-merge-props": "1.4.0",
2 years ago
"@vue/babel-plugin-jsx": "1.1.1",
"@vue/compiler-sfc": "3.2.45",
"@vue/test-utils": "2.2.6",
"autoprefixer": "10.4.13",
"babel-loader": "8.3.0",
2 years ago
"babel-plugin-lodash": "3.3.4",
"chai": "4.3.7",
2 years ago
"chalk": "1.1.3",
"chromedriver": "108.0.0",
"connect-history-api-fallback": "2.0.0",
2 years ago
"copy-webpack-plugin": "11.0.0",
"cross-spawn": "7.0.3",
"css-loader": "6.7.3",
"css-minimizer-webpack-plugin": "4.2.2",
2 years ago
"custom-event-polyfill": "1.0.7",
"eslint": "8.31.0",
"eslint-config-standard": "17.0.0",
"eslint-formatter-friendly": "7.0.0",
"eslint-plugin-import": "2.26.0",
"eslint-plugin-n": "15.6.0",
"eslint-plugin-promise": "6.1.1",
"eslint-plugin-vue": "9.8.0",
2 years ago
"eslint-webpack-plugin": "3.2.0",
2 years ago
"eventsource-polyfill": "0.9.6",
"express": "4.18.2",
2 years ago
"function-bind": "1.1.1",
2 years ago
"html-webpack-plugin": "5.5.0",
"http-proxy-middleware": "2.0.6",
"iso-639-1": "2.1.15",
2 years ago
"json-loader": "0.5.7",
"karma": "6.4.1",
"karma-coverage": "2.2.0",
"karma-firefox-launcher": "2.1.2",
"karma-mocha": "2.0.1",
2 years ago
"karma-mocha-reporter": "2.2.5",
"karma-sinon-chai": "2.0.2",
"karma-sourcemap-loader": "0.3.8",
"karma-spec-reporter": "0.0.36",
"karma-webpack": "5.0.0",
"lodash": "4.17.21",
"mini-css-extract-plugin": "2.7.2",
"mocha": "10.2.0",
"nightwatch": "2.6.3",
"opn": "5.5.0",
"ora": "0.4.1",
"postcss": "8.4.20",
"postcss-loader": "7.0.2",
"sass": "1.57.1",
"sass-loader": "13.2.0",
7 years ago
"selenium-server": "2.53.1",
"semver": "7.3.8",
"serviceworker-webpack5-plugin": "2.0.0",
"shelljs": "0.8.5",
"sinon": "14.0.2",
"sinon-chai": "3.7.0",
"stylelint": "13.13.1",
2 years ago
"stylelint-config-standard": "20.0.0",
"stylelint-rscss": "0.4.0",
"vue-loader": "17.0.1",
"vue-style-loader": "4.1.3",
"webpack": "5.75.0",
"webpack-dev-middleware": "3.7.3",
"webpack-hot-middleware": "2.25.3",
"webpack-merge": "0.20.0"
7 years ago
},
"engines": {
"node": ">= 16.0.0",
7 years ago
"npm": ">= 3.0.0"
}
}